Вопросы по работе системы



  • @Erik Добрый день, сообщите нам если проблема повториться



  • Вот такую штуку получил:
    f06276b1-7de6-4115-8460-3ae7922c7fec-image.png
    Записал в уставку аналогового датчика текст)



  • @homa Добрый день, все верно, не надо так делать ☺ Элемент слайдер ожидает число для регулирования уставки, по этому и ругается. Мы добавили global в сниппеты, используйте их, сегодня выпустим новую версию и можете пробовать. 👍



  • @dev Не получится. Там нужно преобразовать число именно в текст)
    Global d сниппетах использую для других задач, обновление видел, поставил, но значение не попадает в переменную...

    loc = 'd';
    global.set(4, loc);
    

    ce4df63c-b6b3-4184-9a74-222f34fdbba8-image.png



  • Напомните, пожалуйста, или сделайте лучше статью по созданию состояний устройств (аналоговые датчики) и их адекватному отображению на мнемосхемах.
    Для аналогового датчика сделал 3 состояния: холодно (ниже 0), норма (ниже 10), тепло (ниже 20). Вытянул устройство на мнемосхему, выбрал "Значения в виде текста", для всех 3-х состояний настроил цвет фона и шрифта. Однако при изменении температуры датчика его внешний вид не меняется:(



  • @Alex_Jet, на вкладке Дополнительно самый первый параметр : Метод определения состояния нужно установить в "Аналоговое значение - интервалы"



  • @intrapro, отлично! Заработало:)



  • Заметил один момент. Имею в проекте актуатор, нажимаю на него он работает, ( реле у меня щелкает ), потом ставлю галочку в настройке устройства " автоматический режим" затем я убираю галочку с" автоматического режима" и актуатор уже не нажимается. Если на плане подержать значок этого актуатора мышкой, появляются ключики ( где должно быть время с момента включения и отключения ), но они не активны. Т.е состояние на картинке on off меняется, а в реальности не срабатывает. После перезагрузки самого IH, актуатор работает. Скажите пожалуйста, это так задумано? Логи плагина не отслеживал. Прошу прощения если написал невнятно)



  • Добрый день! подскажите пожалуйста как сделать так что бы из вебки и из приложения можно было перезагрузить интру ( из админки это возможно), не найду как ?



  • При перезагрузке ih заблокированые сценарии стают разблокированы, можно поправить?



  • Здравствуйте. Почему-то если на диммере убрать галочку с «установить значение по дефолтному» в настройках устройств и потом вернуть ее на место, то диммер перестает работать, т.е если делаю значение 100 долгим удержанием на значок диммера, с верху значение резко становится 100 и через секунду возвращается в 0. После перезагрузки IH опять все работает нормально. Писал выше, что и с актуатором то же самое происходит.



  • @artem521, Добрый день!
    По актуатору у вас это было связано с переключателем авто, у диммера проблема возникает при настройке уставки? К какому железу подключены устройства, к MegaD? Если ситуация воспроизводится, пришлите пожалуйста логи плагина в момент переключения. И журнал устройства с основного интерфейса в этом же интервале. Можно начать с актуатора



  • @m_n61rus, добрый день!
    Пока такого функционала нет 😞



  • @intrapro В журнале все как обычно, включено/выключено. А вот в отладчике что. https://yadi.sk/i/j61iqSV7PV1ojg у меня там привязан датчик к этому актуатору еще t6703 он сидит на другой меги 2561, а актуатор на megad328. Это все происходит после того, как я ставлю галочку в актуаторе "авто" потом сохраняю, а потом снова убираю галочку и сохраняю. Перестает работать, только после перезагрузки все становится ок.



  • @artem521, это происходит с конкретным актуатором или с другими тоже?

    Нужно проследить соответствие действий в журнале устройств и лога плагина
    Команда в журнале должна приводить к передаче данных на плагин.
    Скриншот.png
    В отладчике плагина в момент отправки команды в журнале должна быть команда плагину от сервера.

    Попробуйте также переключать актуатор не кликом, а кнопками ВКЛ - ВКЛ.
    lamp_on_off.png

    После этого пришлите системный лог - файл /opt/intrahouse-c/log/ih.log на support@ih-systems.com. Желательно еще скриншоты журнала устройства.



  • @intrapro Здравствуйте. Хорошо, с работы приду и сделаю как Вы рекомендуете. Я еще сегодня попробую с другими устройствами, но вроде, по памяти с другими устройствами тоже самое происходит после (поставить галочку на "есть автоматический режим" потом сохранить, потом снова убрать галочку и сохранить).



  • Здравствуйте.
    Установил систему на Android.
    Не ставятся плагины (пробовал MegaD и telegram), установка висит с NaN%.
    А так же хотелось бы узнать, можно ли обновить систему без подключения к интернету? Сейчас стоит версия 4.4.15. Может и плагины не ставятся из-за старой версии.



  • @artem521, обнаружен баг, который сбрасывал (но не удалял) привязку к железу после редактирования свойств устройства. Ошибка была внесена в версии 4.6.14 при добавлении механизма сниппетов

    Выпущена новая версия 4.7.0, проверьте, все должно работать



  • @intrapro как раз тестирую)) сейчас буду пробовать



  • @cerber
    Без интернета обновить систему невозможно.
    Плагины MegaD и Telegram должны работать. Надо обновить систему.


Log in to reply