Beta версия IH SmartHome V5



  • @dev Добрый вечер. Возвращается аналогичная ошибка: "sudo: /opt/ih-v5/node/bin/node: команда не найдена" Система Linux Lint 18.3 Sylvia, ядро 4.10.0-38-generic i686 (32bit)



  • Пользователь @intrahouse написал в Beta версия IH SmartHome V5:

    Плагины.
    Все плагины, у которых первая цифра 5 в номере версии, готовы для работы с системой iH Smart Home V5.
    На текущий момент для V5 работают следующие плагины:
    Emuls - эмулятор сенсоров и актуаторов. Поставляется в комплекте с системой.
    MQTT - для работы с оборудованием по протоколу MQTT
    https://github.com/intrahouseio/intraHouse.plugin-MQTT/archive/v5.0.0.zip
    MegaD - для работы с контроллером MegaD
    https://github.com/intrahouseio/intraHouse.plugin-MegaD/archive/v5.0.0.zip

    Где можно это отслеживать? Вот, жду я , например, плагин модбас, сяоми, бродлинк. Где мне смотреть, не вышла ли версия 5?



  • Пользователь @phlexey написал в Beta версия IH SmartHome V5:

    i686 (32

    Добрый день, к сожалению p2p плагин больше не поддерживает Linux X86 (i686 - 32bit). Пакет WebRTC который мы используем больше не поддерживает данную архитектуру.



  • @Erik Правильное замечание. Сегодня постараемся опубликовать на сайте.



  • @Erik На сайте опубликован плагин Modbus для V5



  • Пользователь @gis написал в Beta версия IH SmartHome V5:

    Здравствуйте! Когда ждать доработаки HTTP плагина для работы с версией 5?

    Повторю вопрос: Когда ждать доработаки HTTP плагина для работы с версией 5?



  • @gis Ответить по срокам не могу. В настоящее время занимаемся сценариями.



  • Пользователь @intrahouse написал в Beta версия IH SmartHome V5:

    @gis Ответить по срокам не могу. В настоящее время занимаемся сценариями.

    Спасибо за ответ! Буду ждать информации....



  • Добрый день! Плагин SNMP планируется обновлять до 5 версии?



  • @poliak000
    Да. Все плагины будут обновлены для работы с v5



  • Баг-репорт плагина ModBus.

    У меня устройство модбас может поддерживать соединение только с одним сервером. Если к нему обращаться с двух серверов - получаем ошибки.

    Соответственно, при тестировании версии 5 я выключаю плагин модбас на версии 4. Для нормальной работы версии 4 я выключаю плагин на версии 5.

    Но, выключенный плагин на версии 5 продолжает слать пакеты на модбас устройство, и в версии 4 идут ошибки:
    Плагин выключен:
    alt text
    В снифере пакетов видны подключения между сервером и модбас устройством
    alt text
    обмен достаточно активный
    alt text
    версия 4 получает ошибки
    alt text
    судя по отсутствии информации в заголовках, пакеты не совсем валидные. Штатный обмен выглядит по другому.
    alt text

    Избавиться от траффика и ошибок помогает только выключение сервера с версией 5.


Log in to reply